HELP PLEASE!!!

I have a MIB 4M0 035 041 which I tried to use "flashit" to re-flash IFS-ROOT-IFS but missed the argument "-d" (flashit -a 540000 -f ifs-root.ifs) and appeared to corrupt my MIB2 as when I rebooted it nothing worked. It became none responsive and I pulled it out of my car and connected to the TTL ports and ESO ports on the Quadlock on my workbench. I found I could get into IPL and it was booting into Emergency Recovery. I could log into Emergency Recovery but I couldn't find any mounts for the SDcard yet I have access to "flashit". I thought the MMX might not be loading because I had the MIB2 on my bench without screen and keyboard so I plugged it back into my car hoping it would get past the mounting errors and I got the same thing. No MMX and nothing on the screen.

I have noticed the following message when the Emergency image is loading "Is the MMX board connected and powered up?"

I get the following output from the ESO pins:

/ > <.STARTUP>
<cpu>: nVidia Quickboot 17.27.13 (Build Jul 2 2015)
<cpu>: modified by e.Solutions GmbH
<cpu>: Loading stage 2 primary bootloader...
<cpu>: Stage2 loaded
<cpu>: Primary partion invalid, trying to boot from recovery image
<cpu>: Failed to boot recovery image!
<cpu>: No bootable kernel image found, giving up

So next I erased the header of the IFS-ROOT.IFS to invoke MIBEmergency (flashit -a 540000 -e 1000 - was "verified")... It now goes into Emergency Recovery as expected and then shows "Starting MIBEmergency..." but then enters back to Emergency Recovery with the following being the last things displayed before the login prompt:

Persistance is not complete
SWDL: Stopping EFS driver!
result of running command stop_efs_driver.sh is 0
SWDL: Starting EFS driver (automount)!
ECC mode is enabled
/HBpersistence/SWDL is available!
Lock flash
[flashlock] locking flash
0 image type=1(IPL ) 0... 1ffff ( 131072)|0...1 (1):LOCKED
1 image type=2(IFS ) 20000... 3b0d43 ( 3738948)|1...30 (29):LOCKED
2 image type=2(IFS ) c20000...1ab7923 (15300900)|97...214 (117):LOCKED
3 image type=4(DSP ) 3d00000...3d963ab ( 615340)|488...493 (5):LOCKED
4 image type=5(BIOS) 3f00000...3f5325f ( 340576)|504...507 (3):NOT LOCKED
result of running command flashlock is 0
ERROR: /net/mmx/ramdisk/eassist doesn't exist
/HBpersistence/SWDL/update.txt doesn't exist
/HBpersistence/SWDL/update.txt.backup doesn't exist
startUpdate 1
Don't use update.txt
SWDL: Mount from medium 3 (0). ResetReleaseSearch 1
OnOff: DeviceName RCC
Display: Info1Text RCC
ERROR: /net/mmx/ramdisk/eassist doesn't exist
Failed to output Info1Text RCC


We assume production mode is not active
Display: Info3Text Try medium USB
Try medium USB
ERROR: /net/mmx/ramdisk/eassist doesn't exist
Failed to output Info3Text Try medium USB


SWDL: mount failed (1)